Results 1 to 2 of 2
  1. #1
    binglis9 is offline Novice
    Windows 10 Access 2016
    Join Date
    Nov 2022

    link tables on a map network dirve

    I have a file server running debian 10 using iptables. Contected is 4 windows 10 desktops with microsoft access database front ends. The tables are stored on a map drive on windows 10 which points to a shared folder where the tables are stored on the file server.

    All works how it should and no problems.

    I have built a new testing server with debian 11 bullseye using nftables. It is the excact same setup but the only difference is nftables. I first tried it using iptables but it didnt work. Had the same problem that follows. The 4 desktops connect ok to the map drive and can read tables ok. If one desktop makes a change to a text field the changes show up on all other machines. If another machine makes a change to the same field same record it shows the change on the two other machines but the first machine that made the orginal change the new edit doesnt show. I can reload the records from the start and all changes are shown correctly. I know from past experience that this alone means the database is not working correctly. Every field is unbound to the database and only when you make a change to the field it writes back to tables and the change is made in the tables correctly.

    I had this problem when I tried to update to bulleyes when first released. I re-installed buster debian 10 as it works there with no problems. I now have more time to investigate and to find out why this happens.

    I have now created a table that logs any updates on any field in each record. this is timestamped and the user who made the change and logs old data. When I make a change all logs are correct and the database table shows correct data.
    This now makes me think its a cache problem. I cant understand why it works with iptables and buster but not with nftables and bullseye.
    Has anyone any views on this. I just seem to be going round and round in circles.

  2. #2
    binglis9 is offline Novice
    Windows 10 Access 2016
    Join Date
    Nov 2022
    does anyone else use a linux file server using samba to store their access tables on. The tables are stored via a map drive that points to the tables on the linux server. I have had this working fine for over 10 years but its only now that things dont seem to work properely. I tried to upgrade to a different plateform and records disappear and edits dont seem to work properely. Mapping a drive on each desktop has worked in the past but it looks like there is some sort of security issue now and the newer platforms dont work. I am trying to find a work round but running out of time. Any help would be appreciated.

Please reply to this thread with any new information or opinions.

Similar Threads

  1. Replies: 4
    Last Post: 11-03-2020, 10:32 AM
  2. Check Link to DB tables and re-link
    By alberigo67 in forum Programming
    Replies: 2
    Last Post: 08-11-2020, 09:52 AM
  3. Re-Link to backend data on network attached storage
    By GraeagleBill in forum Access
    Replies: 6
    Last Post: 06-11-2018, 05:10 PM
  4. Link to network folder from access form
    By recon2011 in forum Forms
    Replies: 1
    Last Post: 08-07-2014, 10:15 AM
  5. Replies: 1
    Last Post: 05-15-2014, 07:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Other Forums: Microsoft Office Forums