Results 1 to 4 of 4
  1. #1
    rogeye is offline Advanced Beginner
    Windows 7 64bit Access 2007
    Join Date
    Nov 2017
    Posts
    36

    ACCESS 2007 SECURITY WARNING Certain content in the database has been disabled OPTIONS

    When I open a DB I copied over from an XPS15 (WIN7) into an XPS12 (WIN 7 or WIN10) laptop, I get s security warning. I have to select ENABLE CONTENT to be able to run my main FORM against my table and its one to many relationships (or even open a table). Is there a way to turn off that security warning and everything associated with security checking?



    Why is ACCESS running any security surveillance?

    The XPS15 platform and my 55KB dbase (ACC2007) runs lightning fast and I never saw this security warning for since the initial days 12 + years.
    So why is it that if I have an XPS12 with ACC2007 all of a sudden I see this ENABLE CONTENT stuff?

    Even after I enable the content, could this "Security Survellance" be slowing down the I/O between the form and the table and all the one-to-many tables?

    I ask these questions because for some reason, this "application" I have been using for a dozen years with zero problems, all of a sudden, runs very slow on this new XPS12 platform. THE XPS12 has enough RAM and hardware so that I don't believe memory is the problem.

    I also notice that on the XPS15, the maintable uses autonumber long integer as the primary key, however INDEXED=NO and when I right click on that field called "ID" it is not possible toggle "PRIMARY KEY", ditto if I click on the DESIGN menu. Yet when I copy the DB onto the XPS12, I am forced to ENABLE CONTENT, and when I open that main table, the "ID" field is already toggled to PRIMARY KEY, INDEX= YES(no duplicates) is mysteriously defaulted (still autonumber longinteger). While true, that is how the ID field functions and I don't have any objection to the setting, it seems odd that the ACC2007 "environment" on the XPS12 looks and feels different. And so I wonder if the performance speed difference is somehow linked to some background security surveillance that is checking each I/O from the table to the form?

    The degradation in speed to populate the form each time I move from field to field on the form is bad enough (3 to 7 seconds from field to field) that I am putting myself through all kinds of efforts to cut the DB size down to 33KB and figure out some sort of ARCHIVE "System" and learn about APPEND and SET and all kinds of programming concepts I have almost no experience with. So if my performance issue is really the security, then if I could eliminate that, maybe I don't need to figure out all this other complicated ARCHIVAL approach.

    It just doesn't make sense to me that a DB application works great on WIN 7 [8 RAM] on one laptop and gets dog slow on another equivalent device.

    Any insight out there?

  2. #2
    ranman256's Avatar
    ranman256 is online now VIP
    Windows Vista Access 2010 32bit
    Join Date
    Apr 2014
    Location
    Kentucky
    Posts
    9,054
    set TRUSTED LOCATIONS , in the options for TRUST SETTINGS
    add your folder and you wont get the warnings.

    access file, options
    (left pane) trust center tab
    button: TRUST CENTER SETTINGS
    (left pane): TRUSTED LOCATIONS tab
    button ADD NEW LOCATION

    -and maybe:
    left pane: MACRO SETTING
    Enable all macros

  3. #3
    Ajax is online now VIP
    Windows 10 Access 2010 32bit
    Join Date
    Mar 2015
    Posts
    9,584
    he/she figured it out this morning - but couldn't resist taking a swipe - seems you're in his/her good books

    https://www.accessforums.net/showthr...429#post488429

  4. #4
    ssanfu is offline Master of Nothing
    Windows 10 Access 2010 32bit
    Join Date
    Sep 2010
    Location
    Anchorage, Alaska, USA
    Posts
    9,510
    rogeye made it to my ignore list...
    HTH
    -----
    Steve
    --------------------------------
    "Veni, Vidi, Velcro"
    (I came; I saw; I stuck around.)

Please reply to this thread with any new information or opinions.

Similar Threads

  1. Security warning Certain content disabled...
    By Jennifer Murphy in forum Security
    Replies: 8
    Last Post: 01-20-2015, 01:07 AM
  2. Disable security warning to "enable content"?
    By Heatshiver in forum Security
    Replies: 2
    Last Post: 02-03-2012, 02:26 PM
  3. Access 2007 Database Backend Security
    By bakkouz in forum Access
    Replies: 2
    Last Post: 10-10-2011, 11:12 AM
  4. Access 2007 Database Security - Passwords
    By AccessFreak in forum Forms
    Replies: 1
    Last Post: 01-03-2011, 09:13 AM
  5. Replies: 1
    Last Post: 02-04-2010, 11:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Other Forums: Microsoft Office Forums