Results 1 to 4 of 4

List Box object not updating for each page in print preview

  1. #1
    kgmanager is offline Novice
    Windows 7 64bit Access 2007
    Join Date
    May 2013
    Posts
    3

    List Box object not updating for each page in print preview

    Hello All!

    I have a report that is header grouped to each ID of my maintable to ensure that each entry in the table gets its own page in the report.The report gathers data from two places: 1) The main table 2) A List Box in thereport uses a query to list items from two other tables that are keyed to themain table.



    I hope the above makes sense. Here is my issue: The maintable has 250 entries, which successfully generates 250 pages in report printpreview that each has the data that they should. However, the list box repeatson every page with the data that it should, but only from the first ID of themain table. (The list box on page 1 is correct, but the other pages are notbecause the list box repeats the data from page 1 on all of them).

    The query for the list box uses the criteria that the secondarykey of another table needs to match the main table ID shown on the report page.Again, works good on the first page, but does not update the list box object onsubsequent pages.


    Please help!

    Thanks,
    Kyle

  2. #2
    June7's Avatar
    June7 is offline VIP
    Windows 10 Access 2010 32bit
    Join Date
    May 2011
    Location
    The Great Land
    Posts
    48,351
    On a form, conditional listbox has to be requeried when navigating records. Not sure this is even possible with report.

    It's unusual to have a listbox on report. Perhaps you should use a subreport.
    How to attach file: http://www.accessforums.net/showthread.php?t=70301 To provide db: copy, remove confidential data, run compact & repair, zip w/Windows Compression.

  3. #3
    kgmanager is offline Novice
    Windows 10 Access 2016
    Join Date
    May 2013
    Posts
    3
    Thanks, June! I didn't know I could do that. One otherquestion on my reports: My reports use an 8.5x11 background image with text boxes(and subreport) on top to present my results. There is a major inconsistencybetween the views (layout, design, print preview) in my report. The positioningof my controls shifts around between the views. I need to match up “perfectly”with my background image to make the report legible. Do you know what is goinghere?
    Thanks again,
    Kyle


  4. #4
    June7's Avatar
    June7 is offline VIP
    Windows 10 Access 2010 32bit
    Join Date
    May 2011
    Location
    The Great Land
    Posts
    48,351
    I have done that once before but only review report in PrintPreview or send direct to printer.

    I almost never work with layout view for forms or reports.

    However, my image is not inserted as background in report Picture property - it is in an Image control.
    How to attach file: http://www.accessforums.net/showthread.php?t=70301 To provide db: copy, remove confidential data, run compact & repair, zip w/Windows Compression.

Please reply to this thread with any new information or opinions.

Similar Threads

  1. Replies: 1
    Last Post: 01-24-2019, 12:58 AM
  2. Replies: 1
    Last Post: 06-27-2017, 08:37 AM
  3. Replies: 1
    Last Post: 11-11-2016, 07:02 PM
  4. Replies: 21
    Last Post: 08-06-2013, 01:02 PM
  5. Replies: 2
    Last Post: 02-08-2012, 01:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Tech Forums: Microsoft Office Forums