Results 1 to 5 of 5
  1. #1
    jpar39 is offline Novice
    Windows 10 Access 2016
    Join Date
    May 2018

    Error: Could not find field

    Hello -

    I've seen similar issues posted elsewhere, but none of the solutions have worked for me. I linked a SharePoint list to Access to serve as a UI for updating the list. From the linked table, I created queries to show the information different groups would need to update, then created forms for each group. As far as I could tell, everything seemed to work as expected while the database was on my hard drive. However, when I loaded it to the SharePoint site where I planned to store it for general access, random items started throwing a "Could not find field" error when users would attempt to change them. I checked all the data types and they all seem to be in order. I refreshed the table link and even created an entirely new database. I'm at a loss as to what could be causing this to happen - there doesn't appear to be any real logic behind which records throw the error. Can anyone help? I'm quite new to Access, so I hope this is just something obvious I'm missing.


  2. #2
    Perceptus's Avatar
    Perceptus is offline Expert
    Windows 10 Access 2016
    Join Date
    Nov 2012
    Knoxville, Tennessee
    I have no idea about sharepoint. Are you preparing your own sql statements for the data transactions?

  3. #3
    Micron is online now Virtually Inert Person
    Windows 10 Access 2016
    Join Date
    Jun 2014
    Ontario, Canada
    When you put an Access table into SP as a list, the data types can get messed up. Check to make sure they are identical.
    The more we hear silence, the more we begin to think about our value in this universe.
    Paraphrase of Professor Brian Cox.

  4. #4
    KJAdams is offline Novice
    Windows 11 Access 2016
    Join Date
    Dec 2022
    I am also using SharePoint as a backend to Access. Had the "Could Not Find Field" error as well. Discovered that the field, Social Security Number, was limited to 11 characters in SharePoint (nine digits plus dashes). I was using the append query to add in records imported from Excel into a temp front end table. One of the SSNs had a leading space, making it 12 characters in length. Once fixed that, the query worked fine.

  5. #5
    Join Date
    Jan 2017
    Swansea,South Wales,UK
    That is why I use Trim() a lot?
    Please use # icon on toolbar when posting code snippets.
    Cross Posting:
    Debugging Access:

Please reply to this thread with any new information or opinions.

Similar Threads

  1. Can't find referenced field error
    By Thompyt in forum Programming
    Replies: 7
    Last Post: 09-04-2015, 09:00 AM
  2. Replies: 3
    Last Post: 10-10-2014, 06:29 PM
  3. Replies: 1
    Last Post: 12-01-2012, 12:44 PM
  4. Replies: 12
    Last Post: 09-14-2012, 04:59 PM
  5. Replies: 5
    Last Post: 06-09-2012, 12:37 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Other Forums: Microsoft Office Forums