Results 1 to 2 of 2
  1. #1
    maaidin91 is offline Novice
    Windows 10 Access 2016
    Join Date
    Apr 2018

    Post After linking to SP > Not able to enter data on a few forms "Cannot Update: Database is read-only"

    Hey all,

    If anyone could help save my job, I will have a pizza delivered to your doorstep.. I am having 2 issues.

    1.) I exported about 9 tables to sharepoint. But for 2 tables there were duplicates created in SP. For instance, "Project_tbl" Created in sharepoint, "Project_tbl", "Project_tbl_1", "Project_tbl_2", "Project_tbl_3"..., "Project_tbl_7".

    This doesn't seem to effect when I enter data in the Access mainform/subform. It only updates the Project_tbl List in Sharepoint. I just want to make sure this is okay and it's not the cause of the 2nd issue I'm having.

    2.) So the mainform/subform works for both FE and BE, But on the sub-sub form whenever I try to enter data I get "Cannot Update. Database or Object is read-only".

    *Note this database worked flawlessly until I started exporting to SP

    Things I have tried:
    • Compact & Repair
    • Both Refresh and relink Tables to SP
    • Copy and paste into a blank database
    • Options>Current Database>Caching web Services and Sharepoint tables> Uncheck "Use the cache format....", also tried checking "never cache" ------> This creates a new message error when entering data "You cannot reference rows created when you are disconnected from the server because this violates the lookup settings defined for this table or list. Please reconnect all tables with the server and try again"
    • Checked administrative restrictions in Sharepoint.

    Any help is much appreciated, Thanks friend.

  2. #2
    Perceptus's Avatar
    Perceptus is offline Expert
    Windows 10 Access 2016
    Join Date
    Nov 2012
    Knoxville, Tennessee
    Issue 1 should not be related to Issue 2.

    Not being up on SP let me say you should check your connection string. or whatever connects.

    You may want to check to make sure the relationships are still in place, maybe your sub data is looking for a parent and upon not finding it cant update.

Please reply to this thread with any new information or opinions.

Similar Threads

  1. Replies: 4
    Last Post: 12-20-2017, 07:33 AM
  2. Error: "Cannot update. Databse or Object is read-only" Issue
    By excellenthelp in forum Programming
    Replies: 4
    Last Post: 07-30-2014, 11:28 AM
  3. Replies: 8
    Last Post: 07-15-2014, 05:56 PM
  4. Replies: 14
    Last Post: 08-19-2013, 09:37 AM
  5. Replies: 0
    Last Post: 10-13-2009, 11:54 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Tech Forums: Microsoft Office Forums