Results 1 to 5 of 5
  1. #1
    jecho_nl is offline Novice
    Windows 10 Access 2013 32bit
    Join Date
    Jan 2017

    Strange error

    Hi everyone,
    I am new here and I am not sure if this is the right group, else please move my tpoci tho the correct group.
    I have a strange situation.
    A friend of my has made a file in MS Access 2013
    On his computer and laptop it is working fine. (I think he is using windows 10 on both)
    When I copy the file to my computer, it does not want to work.
    First I was getting the message that I had to turn on Macro's
    So I had changed this to allow all macro's
    Now when I try to open the file, I am getting an error;
    Undefined function ‘Str’ in expression

    I only have two options I can choose.
    I can click on OK or HELP

    When I click on HELP, a website page is opened and it will try to explain what is wrong;
    “You entered an SQL expression that includes a Function procedure name that cannot be recognized. Make sure the function can be used in SQL expressions, or check the expression to make sure you entered the name correctly."

    When I click on OK a new window will pop-up with the following;
    Macro Single Step

    Macro Name:

    (this field is empty)

    Action Name:

    MembersExtendedMembers; Datasheet; Edit

    Error Number:

    In this window, I only can click "Stop All Macro's"
    When I do this, I end-up with a empty field/workspace.

    I had try this file on several computers.
    On my Windows 10 with Office 2010 and on a laptop with Windows 10 and Office ProPlus (UK) 2013
    Both are doing the same thing.
    Does anyone has any idea, why the file is working on both his computers, but not on mine ?
    We also had tried the file on a clean Windows 10 laptop with Office 2013 from him, and it is working there without any problem.

    For me this is very strange.
    I am new to MS Access, but any which way I look at it, it should work.
    Many thanks for all your help, tips and tricks.

    Gr. Pierre

  2. #2
    RuralGuy's Avatar
    RuralGuy is offline Administrator
    Windows 10 Access 2013 32bit
    Join Date
    Mar 2007
    8300' in the Colorado Rocky Mountains
    I would look at the references and see if you have a BOGUS missing one. Just uncheck it if you do and recompile.
    (RG for short) aka Allan Bunch Previous MS Access MVP - WinXP Pro, Win7 Pro Win10 Pro - acXP, ac07, ac10, ac13
    How to mark the thread as Solved!
    Teaching is not filling a bucket but lighting a fire.
    Borrowed quote..."Docendo discimus"

  3. #3
    Bulzie is offline VIP
    Windows 7 64bit Access 2007
    Join Date
    Nov 2015
    Also, go into a code window(design on a form, then hit the code icon) and in the Debug section do a Compile, see if it gives you any errors. If not, hit save after the compile. If you have a reference issue it should flag it there as well.

    Just a tip you should always do this when running programs on a different version of Access and Office just to clear up any bugs that might happen.

  4. #4
    ranman256's Avatar
    ranman256 is online now VIP
    Windows Vista Access 2010 32bit
    Join Date
    Apr 2014
    Undefined error of simple and ACTUAL built in functions is the cause of a bad reference in the VB environment (VBE)
    press Ctrl-G to get to VBE,
    in the menu: tools, references,
    one of the items is checked ,yet says MISSING.
    uncheck this bad ref.

    the other PC does not have the same versions.
    If the new PC had missing Excel v10,
    but it Does have Excel v11, then check mark this new version.

  5. #5
    jecho_nl is offline Novice
    Windows 10 Access 2013 32bit
    Join Date
    Jan 2017
    Hi ranman256,
    Thanks for your tip.
    It looks like it has solved the problem.
    It was something about missing MS Outlook version(s)
    I had unchecked the missing errors and had checked further down the list, the other MS Outlook versions.
    I had started it once and it looks like it is working.
    I will do a few more test to make sure.

    * Update *
    I tried it on several computer that were giving the same error.
    And now it looks like it is working fine.
    Last edited by jecho_nl; 01-30-2017 at 04:14 PM.

Please reply to this thread with any new information or opinions.

Similar Threads

  1. Damaged mdb 2010 file gives strange error message
    By sanchomosso in forum Access
    Replies: 2
    Last Post: 06-07-2015, 06:27 PM
  2. Replies: 8
    Last Post: 06-19-2014, 04:20 PM
  3. May be a strange way to do this, but...
    By DaltonH in forum Database Design
    Replies: 4
    Last Post: 04-18-2013, 04:00 PM
  4. Replies: 2
    Last Post: 03-29-2011, 01:26 PM
  5. Replies: 6
    Last Post: 03-17-2010, 10:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Other Forums: Microsoft Office Forums - Senior Forums