Results 1 to 2 of 2

#Type! error displaying in report

  1. #1
    KACJR is offline Novice
    Windows 7 32bit Access 2010 32bit
    Join Date
    Sep 2012
    Posts
    11

    #Type! error displaying in report

    I have a number of fields in a report that are calculated date fields which work fine as long as the source field is not null. The source field is a text field of the form "yyyy-mm-dd" (which is how SQL Server stores it). I recalculate the source field using DateValue and then display with Short Date format like the user wants. Proper dates convert and display properly but empty source fields display as #Type!. I have tried qualifying the DateValue calculation by checking for a null value or for a field whose length is less than 10 characters. Neither of these seem to prevent the field from displaying as #Type. There are no circular references.



    I' was thinking "Plan B" would be to look for whether the value of the field is #Type! then making the field invisible is it is. However, the isError function does not identify this condition. Is there a function that would look for a #Type! condition and then return true or false depending on the result?

    Kind regards,
    Ken

  2. #2
    InsuranceGuy is offline Competent Performer
    Windows 7 64bit Access 2013
    Join Date
    Aug 2015
    Location
    Colorado
    Posts
    126
    Try testing for whether the field is empty rather than is null and see if it works.

Please reply to this thread with any new information or opinions.

Similar Threads

  1. Replies: 5
    Last Post: 07-15-2015, 01:30 PM
  2. Replies: 0
    Last Post: 12-03-2014, 11:53 AM
  3. Replies: 3
    Last Post: 02-10-2014, 10:21 AM
  4. type error if sub report has null vallue
    By tagteam in forum Access
    Replies: 5
    Last Post: 10-20-2013, 09:45 PM
  5. Replies: 1
    Last Post: 05-11-2012, 10:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Tech Forums: Microsoft Office Forums