I have 2 different kinds of users on this application: New Data Users and the Full Data Users. One of the reports is produced constructing a query in the form code. When I test the generation of the report using one of this users id it worked perfectly, but on the next user it did not. It kept as the owner the first that runs the query. I have tried to fix it in different manners.
1) I had set the owner's permission to view or run the query through TOOL, OPTION, TABLE/QUERIES tab.

2) I can't set the RunPermission to owner in the query's properties because it's an union query and is not possible to see it's properties.
3) I had set the Administer permission for this query for the "Full Data User" and "New Data User" through the TOOLS, SECURITY, USER AND GROUP PERMISSION. When I tested the modification it sets as owner the first user that I tested and the rest loose their Administer permission for deleting, create and run the query.
4) I tried also adding the "WITH OWNERACCESS OPTION" in the SQL code of this query.
5) I added the following instruction before the create query instruction : cat.Users("New Date Users").SetPermissions"query_informe",dbSecFullAcc ess.

What can I do to set this permanently?