I posted this problem about 2 years ago under the title "Access 2010 fails where 2007 worked". Albert K. (Access MVP in Edmonton) was very helpful and I re-designed and re-wrote parts of the application to get it to work. But that was NOT the problem. Here's a timeline. Configuration changes in bold.

2008 Dell laptop; Vista; Access 2007 - application works
2008 Acer desktop; Vista; Access 2007 - application works
(I develop on the laptop and move the application to the desktop)
2010 Dell laptop (same); Windows 7; Access 2007 - application works
(Went to Windows 7 after HD crash; re-installed all applications)
2010 Dell laptop (same); Windows 7; Access 2010 - application FAILS !!!
(Only variable here is Access 2010. HOWEVER, it turns out that the Dell laptop DOES NOT SUPPORT Windows 7. The integrated graphics chip/driver accelerator does not work. Games are impossible, but the application on Access 2007 works. The failure is "Write Conflict" or a runtime error with failure to save record due to multiple changes.)
2011 Toshiba laptop; Windows 7; Access 2007 - application works
2011 Toshiba laptop (same); Windows 7; Access 2010 - application WORKS!!


(The Dell with this configuration fails. See 2010 above.) (Toshiba laptop dies after a coffee bath! Hard disks recovered! Grrrr!!)
2012 Gateway desktop; Windows 7; Access 2010 - application works
2012 Gateway desktop (same); Windows 8; Access 2010 - application works
2012 Acer desktop (same); Vista; Access 2010 - application works
2013 Dell laptop (same); Windows 7; Access 2007 - application works
(Although some 2010 features are crippled (button background color) the application functions normally. Did this to prove something. Not development.)
2013 HP desktop; Windows 8; Access 2010 - application FAILS !!!!
(This is the same failure scenario as with the Dell laptop in 2010. Panic, followed by light-bulb moment!! Find LCD monitor CD that came with HP desktop. Install drivers from CD. Application WORKS!!!)

Could somebody please explain why my application, running on Access 2010, FAILS if, and only if, the graphics driver is unsupported or back level. It is a mystery to me as to why a hardware feature makes or breaks an application which happily runs on Access 2007 with Vista, Windows 7 and probably Windows 8 on any PC even when the graphic driver is failing.