Results 1 to 2 of 2
  1. #1
    allochthonous is offline Novice
    Windows 7 32bit Access 2010 32bit
    Join Date
    May 2006
    Posts
    12

    Corruption problem Access 2000 - long, but please read

    Hello.



    I am a mostly self taught Access newbie with only 6 months experience. I have had a couple of light online courses and a LOT of help from a coworker/friend with quite a bit of Access knowledge. I have been developing a front end/back end database in Access 2000 for work, to be used on a network. The back end will be located on the network, with the front end users having their own local copy of the front end. The back end contains all data entry tables, data compilation queries, and reports. Currently the project has 26 tables (5 linked to external sources), 390 queries, 25 forms, 15 macros, and 481 reports. I would say that I am 80-90% finished and have begun some light beta testing. Though it seems like an impressive piece of work to me, I realize that it is probably not much when compared to other "professionally" built databases.

    Here is my problem:

    I had just finished creating a bunch of reports and assigning the reports to the corresponding buttons on my latest report menu form. After I closed the database and reopened it, I received a warning: "The Visual Basic for Applications project in the database is corrupt." From then on, I could not do anything without that error message popping up and could no longer even access the VBA code. Luckily, I keep an archive of every day's work at the end of the day, so I had only lost about 2-3 hours of work. I reverted back to the previous version, but ran into the same problem after creating a few reports. My coworker is currently using Access 2003, so we tried to run my database through it, and it seemed to work OK, but I was skeptical. Also, not all of the users of my database may have access to 2003, so I wanted to keep it as 2000 friendly as possible.

    I had been working off of a JumpDrive, so my next thought was to eliminate that as a variable. So I copied the last stable version onto my desktop and tried again, but had the same results. Next, I tried another desktop to eliminate that, with the same results once again. Frustrated, I then decided to see of I could determine at which point exactly the "corruption" began. I added the reports and code behind the buttons, saving, closing, and reopening after each one. After the fifth report was created and button activated, the database crashed on opening. I retraced my steps once again, and once again, it failed at the exact same point. My next thought was that perhaps this button was related to the cause, so decided to skip that row of buttons altogether. After retracing my steps again, it failed at the same point, except in the next row.

    Running out of ideas, I even tried importing the form from a previous build and renaming it, but that did not work either.

    My only option at this point was to try Access 2003. I hopped over to a machine that had 2003 running and opened the last stable build. It took a bit to open, but then work just fine. I was able to move quite a ways past the point where it usually broke down. Curious, I decided to take it back over to 2000 to see what would happen now that I had built quite a bit past the threshold. Of course, I received the error.

    OK, does ANYONE have any idea what is going on here? I cannot fathom that I have pushed the limitations of Access 2000. What threshold am I crossing here? Should I just move forward with 2003?

    Please advise!!

    Paul

  2. #2
    StepUP is offline Advanced Beginner
    Windows 7 64bit Access 2000
    Join Date
    Dec 2005
    Posts
    99
    Many incarnations of Access 2000 were notoriously buggy, so its important to make sure you have the latest serive packs for Access and Jet. Check this link:

    http://support.microsoft.com/default...uct=access2000

Please reply to this thread with any new information or opinions.

Similar Threads

  1. Access 2000 programming startup options
    By nosaj_ccfc in forum Programming
    Replies: 2
    Last Post: 10-17-2008, 02:18 PM
  2. very slow when connect to access 2000
    By pureland in forum Access
    Replies: 0
    Last Post: 10-23-2007, 05:42 AM
  3. how long as this been around for.?
    By SOniC in forum Access
    Replies: 0
    Last Post: 04-12-2007, 11:38 PM
  4. Replies: 2
    Last Post: 10-19-2006, 04:37 PM
  5. Problem with Read Only User
    By admaldo in forum Security
    Replies: 0
    Last Post: 04-24-2006, 11:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Tech Forums: Microsoft Office Forums