Results 1 to 6 of 6

Linked tables not pulling field data through correctly

  1. #1
    D4WNO is offline Novice
    Windows 7 32bit Access 2007
    Join Date
    Jun 2012
    Posts
    10

    Question Solved - Linked tables not pulling field data through correctly


    Hi all,

    I'm a bit of an Access noob but have managed to build a very simple database.

    I have a main table which I need to add 4 columns onto the end of, the data for which comes from 4 tables linked to it. Below is how they are linked.

    Main table------> Table 1
    Main table------> Table 2
    Main table------> Table 3
    Main table------> Table 4

    All 4 relationships have a join type of 2 (Include ALL records from 'Main table' and only those records from 'Table1/2/3/4' where the joined fields are equal)

    However, 3 of them pull back the correct data when I refresh the Main table, but the 4th one doesn't - which appears to be to be set up in the exact same way. It does bring back data, but it's the wrong data or in the wrong order.

    For example, if the related field in the Main table is "Sarah" - It needs to bring back "Programme", but some Sarah's pull through Programme, some are blank and some are another option altogether. Table 4 has no duplicates or typos etc and I've tried deleting it, loading it in again and creating a new relationship but nothing seems to be helping, please help
    Last edited by D4WNO; 06-14-2012 at 08:24 AM.

  2. #2
    R_Badger is offline Knows a few tricks
    Windows XP Access 2003
    Join Date
    Feb 2012
    Location
    Suffolk, UK
    Posts
    262
    From the looks of it, I don't think we can do much without at least seeing the SQL for your query or having a look at your project.

    Although you have described your problem, we need a bit more to have something to work with, from the sounds of it, it is likely a relationship issue, but cant tell what, why or how without seeing the SQL or the project as a whole. If you wish to upload your project please remember to strip out any confidential information first, compact and repair and then zip if it is still too large.

  3. #3
    D4WNO is offline Novice
    Windows 7 32bit Access 2007
    Join Date
    Jun 2012
    Posts
    10
    Thanks for your reply, the SQL for the main table is as below. It is "RAGroup" that has the issue.

    SELECT [CERPS Data].*, MarketCountry.Country2, StatusHighStatus.HighStatus, RAGroup.Group2, BusinessType.BusinessType
    FROM ((([CERPS Data] LEFT JOIN MarketCountry ON [CERPS Data].[Current Site] = MarketCountry.[Current Site]) LEFT JOIN StatusHighStatus ON [CERPS Data].Status = StatusHighStatus.Status) LEFT JOIN RAGroup ON [CERPS Data].[Submitter Grp] = RAGroup.[Group+]) LEFT JOIN BusinessType ON [CERPS Data].[Sub Code+] = BusinessType.SubCode;

  4. #4
    D4WNO is offline Novice
    Windows 7 32bit Access 2007
    Join Date
    Jun 2012
    Posts
    10
    Here is a link to a screenshot, it's the "RAGroup" link I'm having issues with:

    http://i47.tinypic.com/359jv6a.jpg

  5. #5
    R_Badger is offline Knows a few tricks
    Windows XP Access 2003
    Join Date
    Feb 2012
    Location
    Suffolk, UK
    Posts
    262
    I have had a look and it seems you have the field linked to a submitter group in the query whereas in your relationship diagram it should be related to group+ (its a little hard to see due to low res)

  6. #6
    D4WNO is offline Novice
    Windows 7 32bit Access 2007
    Join Date
    Jun 2012
    Posts
    10
    Thanks you're an angel, thank you so much for your help

Please reply to this thread with any new information or opinions.

Similar Threads

  1. Pulling field data from another record's field?
    By PeachTosser25 in forum Access
    Replies: 7
    Last Post: 02-06-2012, 01:14 PM
  2. Replies: 3
    Last Post: 01-03-2012, 12:28 PM
  3. Reports not pulling data correctly
    By yes sir in forum Access
    Replies: 13
    Last Post: 04-01-2011, 09:13 PM
  4. Have 3 tables - problem with pulling data for query
    By wulfhund in forum Database Design
    Replies: 2
    Last Post: 08-13-2010, 05:38 AM
  5. Pulling only certain data from tables.
    By stevman22889 in forum Access
    Replies: 2
    Last Post: 07-15-2010, 06:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Tech Forums: Microsoft Office Forums