Results 1 to 3 of 3

Slow Sharepoint List opening 1st time with access

  1. #1
    SteveApa is offline Advanced Beginner
    Windows 7 64bit Access 2010 64bit
    Join Date
    Jan 2015
    Posts
    39

    Slow Sharepoint List opening 1st time with access

    Hi!
    I have an Access DB with linked sharepoint lists. DB runs well, lists are not very big, not a lot of columns... Some days, and some times through out the day, on opening a table for the 1st time after opening the database, it takes a long time to open. But, the 2nd opening is quick.

    On start of the Access DB, with VB, I query an 'Admin' linked table (sharepoint List) with users and compare them to Environ("USERNAME") - this will define the user as an admin or not if they are on the 'list'. This table (right now is 4 lines long and has 4 columns. Some days it only take a couple seconds... Some days it takes 20 sec!



    Seems to me that upon opening the database and making that first request to a sharepoint list - it takes a long time. But the subsequent pings to the table are quick. Sorta like the 1st time opening a table the system needs to find it, but the 2nd time it remembers where it is>>


    Any ideas? Is it a caching thing? Can't be. The table described above only has 4x4 = 16 elements. Some days, it does run very quickly from opening.

    I work for a global top 100 electronics company.

    Thanks.
    Steve
    Harrisburg, PA USA

  2. #2
    AdrianG001 is offline Novice
    Windows 10 Access 2007
    Join Date
    Mar 2018
    Posts
    6
    First, when you say you moved the tables to SharePoint, do you have an on-premises SharePoint site, or is this an Office 365 SharePoint site? If the former, what kind of performance do you get with your network otherwise? Is it simply a factor of network connectivity, in other words? I doubt that, but it's something to consider. Of course, if it's a remote SharePoint site on O365, that's always going to be a consideration.

    Second, did you make sure that all indexes on your local tables were also defined on the SharePoint lists (i.e. tables)? Did you enable the relationships on your SharePoint tables using the Lookup method? I otherwise dislike Lookup fields in tables, but they are required in this situation,

    Third, did you enable caching in your accdb? One of the key factors in performance with SharePoint is that you can enable local caching so that the accdb is using those cached tables as much as possible, greatly enhancing performance.

    Fourth, how "heavy" are the forms in question? Lots of subforms, listboxes and combo boxes? Those tend to have a serious impact on performance when using remote tables (SharePoint lists).

    Adrian Gates
    Sr. Cloud Expert - Apps4Rent

  3. #3
    Perceptus's Avatar
    Perceptus is offline Expert
    Windows 10 Access 2016
    Join Date
    Nov 2012
    Location
    Knoxville, Tennessee
    Posts
    591
    There is a 'known issue' with SharePoint's initial load. SharePoint runs on the .Net framework on IIS, which goes to sleep by itself, or in your case an IISRESET restarts all the services.


    Though the IIS services are running, nothing is going on until that first request is made to the website. At that moment, the .Net Framework has to compile all of the DLLs that comprises SharePoint and its features. So the initial load will take a long time, and the more services/features you're using (User Profile, Metadata, etc), the longer it'll feel as it all wakes up.
    Patience serves as a protection against wrongs as clothes do against cold.

Please reply to this thread with any new information or opinions.

Similar Threads

  1. Opening/closing Anything in Access is slow!
    By cboshdave in forum Access
    Replies: 1
    Last Post: 06-02-2015, 01:27 PM
  2. Slow upload from Access to SharePoint
    By PJ Crittenden in forum SharePoint
    Replies: 2
    Last Post: 09-19-2014, 08:34 AM
  3. Slow access tables linked to sharepoint. How to fix it?
    By flamingos_usa in forum SharePoint
    Replies: 3
    Last Post: 05-03-2014, 08:36 AM
  4. Replies: 2
    Last Post: 01-31-2012, 07:16 PM
  5. Slow Access Loading time
    By alexstoker in forum Access
    Replies: 3
    Last Post: 02-05-2006, 07:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Tech Forums: Microsoft Office Forums