Results 1 to 5 of 5

Page Header missing from Subreport

  1. #1
    cphelps48 is offline Novice
    Windows 7 64bit Access 2003
    Join Date
    Aug 2011
    Posts
    13

    Cool Page Header missing from Subreport

    I have created a report that contains a subreport and it is working very well except for one aspect.

    As I expect that the Subreport will start on the first page and extend over multiple page after that, I have built the subreport so that it has a page header to ensure that columns labels appear at the top of each page.

    When I run the subreport by itself I can see the top row or what is the contents of the page header section of the subreport (refer to attached file SUBREPORT.PDF)

    When the report is run (refer to attached file REPORT.PDF) the first row or page header section of the subreport does not appear.

    I have checked the settings to ensure that properties are set to have that section visible.

    I have attached a third file showing the subreport in design view.

    I would appreciate if anybody could advise what needs to be done to make the Page Header section of the subreport appear in the report.

    subreport.pdf

    report.pdf

    Click image for larger version. 

Name:	Subreport design view.jpg 
Views:	8 
Size:	75.9 KB 
ID:	5352

  2. #2
    June7's Avatar
    June7 is online now Moderator
    Windows XP Access 2010 32bit
    Join Date
    May 2011
    Location
    The Great Land
    Posts
    28,500
    Google: access report subreport page header
    http://bytes.com/topic/access/answer...header-problem
    To provide db: Make copy, remove confidential data, run compact & repair, zip if large - 2mb allowed, attach to post. Attachment Manager is below the Advanced post editor window.
    If suggestion in this post resolves your issue, please use the Thread Tools and mark the thread as Solved!

    Debug!Debug!Debug! http://www.cpearson.com/excel/debug.htm

  3. #3
    cphelps48 is offline Novice
    Windows 7 64bit Access 2003
    Join Date
    Aug 2011
    Posts
    13
    That did it!!!! Thank you!!!!!

    One more question. This is now prompting me to enter a parameter value for 1=1. Is their a way to avoid this?

  4. #4
    June7's Avatar
    June7 is online now Moderator
    Windows XP Access 2010 32bit
    Join Date
    May 2011
    Location
    The Great Land
    Posts
    28,500
    I don't know why it is prompting, shouldn't. I can't replicate the issue.
    To provide db: Make copy, remove confidential data, run compact & repair, zip if large - 2mb allowed, attach to post. Attachment Manager is below the Advanced post editor window.
    If suggestion in this post resolves your issue, please use the Thread Tools and mark the thread as Solved!

    Debug!Debug!Debug! http://www.cpearson.com/excel/debug.htm

  5. #5
    m_mutahir is offline Novice
    Windows XP Access 2007
    Join Date
    Feb 2012
    Posts
    1
    Quote Originally Posted by June7 View Post
    Google: access report subreport page header
    http://bytes.com/topic/access/answer...header-problem
    Thank you! Problem solved.

Please reply to this thread with any new information or opinions.

Similar Threads

  1. Page Header & Forced Page Break
    By Donnydon in forum Reports
    Replies: 1
    Last Post: 09-08-2011, 07:24 AM
  2. Replies: 3
    Last Post: 08-07-2011, 08:22 PM
  3. Replies: 1
    Last Post: 03-30-2010, 10:31 AM
  4. Vertical alignment of page Header
    By diane802 in forum Reports
    Replies: 6
    Last Post: 01-19-2010, 10:54 AM
  5. Report Header on Each Page
    By nweird in forum Reports
    Replies: 1
    Last Post: 07-24-2009, 06:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Tech Forums: Microsoft Office Forums