Results 1 to 3 of 3

Thread: opening forms extra records

  1. #1
    Lupson2011 is offline Advanced Beginner
    Windows XP Access 2007
    Join Date
    Aug 2011
    Posts
    68

    opening forms extra records

    Hi

    When I open my access 2007 database from the switchboard, the form that it opens up to is a parent form with a subform embedded in it. The subform is linked by the 'org name' and by 'year'.

    I am finding that when I open the parent form,there is always an additional empty record in the subform, alongside the record which has data in it.

    I am not sure why it is doing this, especially as when you enter another record, this empty form vanishes. Its almost acting as the default form?

    I have also noticed that when I go to another form which is displaying specific data linked to the 'org name' and 'year' it also has an extra record

    However, the weird thing is it does not show up in the table. And again, once you go to a new organisation and input some data, and then go back to the other organisation,the additional record has gone?

    Is there a simple property setting whereas each time you open the form, it always opens up to where you essentially left off, no empty record?

    any advice appreciated, sorry if this sounds confusing as well..

    thanks

    Lupson2011
    Last edited by Lupson2011; 08-31-2011 at 07:31 AM.

  2. #2
    RuralGuy's Avatar
    RuralGuy is online now Administrator
    Windows 7 64bit Access 2010 32bit
    Join Date
    Mar 2007
    Location
    8300' in the Colorado Rocky Mountains
    Posts
    10,744
    Have you tried setting the Allow Additions property of the form to False?
    (RG for short) aka Allan Bunch MS Access MVP - WinXP Pro, Win7 Pro - acXP, ac07, ac10, ac13
    If your issue is resolved...go ahead and use the Thread Tools at the top of the thread and mark the thread as Solved!
    Teaching is not filling a bucket but lighting a fire.
    Borrowed quote..."Docendo discimus"

  3. #3
    apr pillai's Avatar
    apr pillai is offline Contributor
    Windows 7 64bit Access 2007
    Join Date
    May 2010
    Location
    Alappuzha, India
    Posts
    134
    Is there a simple property setting whereas each time you open the form, it always opens up to where you essentially left off, no empty record?
    I can show you an example on the above quoted issue at the following link: Saving data on Forms not in Table

Please reply to this thread with any new information or opinions.

Similar Threads

  1. Two forms opening the same form
    By MikeMairangi in forum Forms
    Replies: 5
    Last Post: 08-31-2011, 12:55 PM
  2. Opening Forms Multiple Arguements
    By Lupson2011 in forum Access
    Replies: 10
    Last Post: 08-30-2011, 07:51 AM
  3. Opening Forms Multiple Arguements
    By Lupson2011 in forum Forms
    Replies: 1
    Last Post: 08-26-2011, 03:13 AM
  4. Forms opening on new record entry
    By daddylongtoe in forum Forms
    Replies: 4
    Last Post: 06-28-2010, 03:15 AM
  5. Access freezes when opening forms
    By thorpef1 in forum Access
    Replies: 0
    Last Post: 01-04-2010, 02:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Tech Forums: Microsoft Office Forums